using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<s>[-+])?(?P<o><)?(?(s)|[-+]?)\d+(?:\.\d+(?:[Ee][-+]\d+(?:\.\d+)?)?)?(?(o)>|)$";
string input = @"-11.88
<0.012541>
-<3.14>
<-2.98>
-<3.2e-32>
-<-2>
<eeeee>
-<3.2e-3.2.2>
-<3.e--3.22>
-<3.ee-3.22>
<1.23
<-abcdefg>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}