package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<s>[-+])?(?P<o><)?(?(s)|[-+]?)\d+(?:\.\d+(?:[Ee][-+]\d+(?:\.\d+)?)?)?(?(o)>|)$`)
var str = `-11.88
<0.012541>
-<3.14>
<-2.98>
-<3.2e-32>
-<-2>
<eeeee>
-<3.2e-3.2.2>
-<3.e--3.22>
-<3.ee-3.22>
<1.23
<-abcdefg>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}