const regex = new RegExp('^(?P<s>[-+])?(?P<o><)?(?(s)|[-+]?)\\d+(?:\\.\\d+(?:[Ee][-+]\\d+(?:\\.\\d+)?)?)?(?(o)>|)$', 'gm')
const str = `-11.88
<0.012541>
-<3.14>
<-2.98>
-<3.2e-32>
-<-2>
<eeeee>
-<3.2e-3.2.2>
-<3.e--3.22>
-<3.ee-3.22>
<1.23
<-abcdefg>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}