# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\w]+)([, ])+(Democratic.+|Republic.+)/$3 $1/gi;t' <<< "Congo, Republic of
Congo, Democratic Republic of
Tunisia
Prague
Sail, Republic
"