# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\w]+)([, ])+(Democratic.+|Republic.+)"
test_str = ("Congo, Republic of\n"
"Congo, Democratic Republic of\n"
"Tunisia\n"
"Prague\n"
"Sail, Republic\n\n\n\n\n\n\n\n\n\n\n\n")
subst = "$3 $1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.