import Foundation
let pattern = #"([\w]+)([, ])+(Democratic.+|Republic.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Congo, Republic of
Congo, Democratic Republic of
Tunisia
Prague
Sail, Republic
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3 $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)