package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<table>)\|(<tr>)\[<td>([^<]*)<\/td>\](<\/tr>)\|(<\/table>)`)
var str = `<table>|<tr>[<td>outro valor</td>]</tr>|</table>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}