using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{2}(?:-\d{2})?(?:,\s*\d{2}(?:-\d{2})?)*$";
string input = @"01,02,03,04
1002003
01,02,03
A, B, C
s01, s02, s02
E2702-2703,E2702-2703
03,05,06
05-08,09,10-12, 05-08";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}