using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!^[^0-9]+$)[^0-9_].{5,17}(.)\1$";
string input = @"9fda32aa
_54lasdbb
fdfjdkalg
dfdkslaa
ds4fdklall
dfd3235
dsd__3*4329_+21fdjfdkjalgkjdkajgkdd
a__++__++321fdall
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}