use strict;
my $str = '9fda32aa
_54lasdbb
fdfjdkalg
dfdkslaa
ds4fdklall
dfd3235
dsd__3*4329_+21fdjfdkjalgkjdkajgkdd
a__++__++321fdall
';
my $regex = qr/^(?!^[^0-9]+$)[^0-9_].{5,17}(.)\1$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}