re = /^(?!^[^0-9]+$)[^0-9_].{5,17}(.)\1$/m
str = '9fda32aa
_54lasdbb
fdfjdkalg
dfdkslaa
ds4fdklall
dfd3235
dsd__3*4329_+21fdjfdkjalgkjdkajgkdd
a__++__++321fdall
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end