using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@media[^\{]+\{([^\{\}]*\{[^\}\{]*\})+[^\}]+\}";
string input = @".visible-desktop {
display: inherit !important;
}
#intro .container {
margin:0 auto;
display:table;
}
@media (max-width: 480px) {
#intro .download-php { margin: 0; }
}
@media (min-width: 768px) and (max-width: 979px) {
.hidden-desktop {
display: inherit !important;
}
.visible-desktop {
display: none !important ;
}
.visible-tablet {
display: inherit !important;
}
.hidden-tablet {
display: none !important;
}
}
body, input, textarea {
font-family: ""Fira Sans"", ""Source Sans Pro"", Helvetica, Arial, sans-serif;
font-weight: 400;
}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}