re = /(?=(\s|\.|,|:|;|\?|\!|^))\1(American Tea)(?=\s|\.|,|:|;|\?|\!|$)/
str = 'American Tea is awesome. Do you like American Tea? love WowAmerican Tea #American Tea, American Tea, American Tea!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end