$re = '/[^e]/i';
$str = 'This is my very long regex test string - I\'m testing it! :)';
$subst = "?";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;