re = /[^e]/i
str = 'This is my very long regex test string - I\'m testing it! :)'
subst = '?'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result