// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[^e]").unwrap();
let string = "This is my very long regex test string - I'm testing it! :)";
let substitution = "?";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}