import Foundation
let pattern = #"[^e]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"This is my very long regex test string - I'm testing it! :)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"?"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)