$re = '/[^,],[^,]/';
$str = '8/15/2016,,Amazon,,15.93
8/24/2016,,Google,18.73
8/26/2016,,Ebay,,60.2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);