re = /['\"](name|anotherkey)['\"]\s*=\s*(?:'([^']*)'|\"([^\"]*)\")/
str = 'atable[\'akeyofthetable\'] = { \'name\' = \'a name\',
\'thevalue\' = 34,
"anotherkey" = \'something\' }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end