#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\.com\/mn"
Local $sString = "http://www.foo.com/mn " & @CRLF & _
"http://www.foodev.com/mn " & @CRLF & _
"http://www.foo.com/MN " & @CRLF & _
"http://www.foodev.com/MN" & @CRLF & _
"" & @CRLF & _
"http://www.foo.com/la/mn " & @CRLF & _
"http://www.foo.com/la/di/da/mn " & @CRLF & _
"http://www.foodev.com/la/mn " & @CRLF & _
"http://www.foodev.com/la/di/da/mn"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")