# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\S+:\h+.*?(?=\h+\S+:)\K\h+/\n/gm;t' <<< "Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook
Action: This Example BB: Bla bla Request: 555\""