import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S+:\\h+.*?(?=\\h+\\S+:)\\K\\h+";
final String string = "Time: 10:40 Request: page.php Action: whatever this is Refer: Facebook\n"
+ "Action: This Example BB: Bla bla Request: 555\"";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}