using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)(n'?t)?\b";
string input = @"Do you like silly hats?
Does this match?
Should we match?
Could we match?
Would it be nice?
Wouldn't it be nice?
Don't match:
Donuts
Cannonball Run
Area 51
Didley squat
Williamsburg
Istanbul
Haskell
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}