const regex = /
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)(n'?t)?\b/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)(n\'?t)?\\b', 'gim')
const str = `Do you like silly hats?
Does this match?
Should we match?
Could we match?
Would it be nice?
Wouldn't it be nice?
Don't match:
Donuts
Cannonball Run
Area 51
Didley squat
Williamsburg
Istanbul
Haskell
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}