// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)(n'?t)?\b").unwrap();
let string = "Do you like silly hats?
Does this match?
Should we match?
Could we match?
Would it be nice?
Wouldn't it be nice?
Don't match:
Donuts
Cannonball Run
Area 51
Didley squat
Williamsburg
Istanbul
Haskell
(?i)^((sh|[cw])ould|can|are|did|will|is|has|does|do)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}