$re = '/(?:\/\/(?:\\\\\n|[^\n])*\n)|(?:\/\*(?:\n|\r|.)*?\*\/)|(("|\')(?:\\\\\\\\|\\\\\2|\\\\\n|[^\2])*?\2)/';
$str = '// /*
/*
This is a multi line comment
// */
// " qwe" dsfdsf "
// This is a single line comment
char cha1[] = "This is a string containing a combination //",
cha2[] = "This has /* a fake comment */ in it",
cha3[] = "This is tuff because of (ignore this //) \\
line continueation",
cha4[] = "Handle comments in strings with \\" escaped quotes\\
and escaped escaped escapes";
char array[] = "Handle comments in strings with \\" escaped quotes\\
and escaped escaped escapes \\\\";
// This is a single line comment \\
continuing on the next line
void main()
{
printf("Hello world!");
return 0;
}
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;