$re = '/(?:\b|^)((?:(?:(?:\d)|(?:\d{2})|(?:1\d{2})|(?:2[0-4]\d)|(?:25[0-5]))\.){3}(?:(?:(?:\d)|(?:\d{2})|(?:1\d{2})|(?:2[0-4]\d)|(?:25[0-5]))))(?:\b|$)/';
$str = '123.123.123.145 is an IP4 so is 1.2.3.4 and 1.22.33.44 but 256.1.2.3 isn\'t 254.1.2.3 is but 260.1.1.1 isn\'t nor 2.5.256.1 and 1.2.3.4:222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);