#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\s*if.*(*SKIP)(*FAIL)|\$\w+\s*=.* (and|or) .*"
Local $sString = "$is_valid = $is_active and !$is_deleted;" & @CRLF & _
"if($is_active and !$is_deleted) {}" & @CRLF & _
"$is_valid = (($cost + $tax) > 20) and ($tax < 3);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")