const regex = /^\s*if.*(*SKIP)(*FAIL)|\$\w+\s*=.* (and|or) .*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*if.*(*SKIP)(*FAIL)|\\$\\w+\\s*=.* (and|or) .*', 'g')
const str = `\$is_valid = \$is_active and !\$is_deleted;
if(\$is_active and !\$is_deleted) {}
\$is_valid = ((\$cost + \$tax) > 20) and (\$tax < 3);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}