re = /\+?\d{1,4}?[-.\s]?\(?\d{1,3}?\)?[-.\s]?\d{1,4}[-.\s]?\d{1,4}[-.\s]?\d{1,9}/
str = 'lkfjlsakjfd sajfldsfk askljfa131432423422'
# Print the match result
str.match(re) do |match|
puts match.to_s
end