// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\[[^\[\]]*\[.*?\][^\]\[]*\])").unwrap();
let string = "[[1,2,3],[3,5,3],[9,8,9]] aoeu [5,6,9] aoeu [[4,5,5]] [[1,2,3],[3,5,3],3]
[[1,2,3],4,[3,5,3],3]
[1,2,3,[3,5,3],3]
[1,2]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}