package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^\W*(der|die|das|the)\W+\b|\b\W+(?1)\W*$`)
var str = `the hobbit, der!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}