$re = '/^\W*(der|die|das|the)\W+\b|\b\W+(?1)\W*$/i';
$str = 'the hobbit, der!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);