use strict;
my $str = 'STRING("safsf", "asf", "asf")
STRING("safsf", "asf")
hasAccess("bs", $this->method(), "b3")
STRING("safsf", "asf", "asf","more)
hasAccess("bs","bs2","b3")
hasAccess("bs","bs2()","b3")
hasAccess("bs2","bs2()", what)
hasA,a,a';
my $regex = qr/hasAccess\((?:[^,]+,){2}[^()]+\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}