Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
hasAccess\((?:[^,]+,){2}[^()]+\)
/
gm
Input 1
1
New
STRING("safsf", "asf", "asf") STRING("safsf", "asf") hasAccess("bs", $this->method(), "b3") STRING("safsf", "asf", "asf","more) hasAccess("bs","bs2","b3") hasAccess("bs","bs2()","b3") hasAccess("bs2","bs2()", what) hasA,a,a