#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^-?[0-9]+(?:\.[0-9]{1,4})?$"
Local $sString = "222,222,264.00" & @CRLF & _
"+2,424,24.34" & @CRLF & _
"-264" & @CRLF & _
"264.00" & @CRLF & _
"0." & @CRLF & _
"0.11111" & @CRLF & _
"0.1111" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")