# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(THE END|FINIS).*//g;t' <<< "txt <- \"... thou hast tam'd a curst shrow. LUCENTIO. 'Tis a wonder,
by your leave, she will be tam'd so. Exeunt THE END <<THIS ELECTRONIC VERSION OF THE COMPLETE WORKS OF WILLIAM ...\"
txt <- \"... thou hast tam'd a curst shrow. LUCENTIO. 'Tis a wonder,
by your leave, she will be tam'd so. Exeunt FINIS <<THIS ELECTRONIC VERSION OF THE COMPLETE WORKS OF WILLIAM ...\""