using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(['""]).*?\1(*SKIP)(*FAIL)|\s*\|\s*";
string input = @"aa | bb | ""cc | dd"" | 'ee | ff'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}