re = /(['"]).*?\1(*SKIP)(*FAIL)|\s*\|\s*/m
str = 'aa | bb | "cc | dd" | \'ee | ff\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end