use strict;
my $str = 'http://a-ads.com/?partner=852501';
my $regex = qr/partner=\K[^&]+/p;
my $subst = '985412';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";