#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\$[^\$]*\$"
Local $sString = "$hello$" & @CRLF & _
"" & @CRLF & _
"$" & @CRLF & _
"hello" & @CRLF & _
"$" & @CRLF & _
"" & @CRLF & _
".projection $I_{d,i} \rightarrow M_{d,i} M_{d,0}$, where all the" & @CRLF & _
"" & @CRLF & _
"\begin{itemize}" & @CRLF & _
"\item $M$ is atomic and finitely generated;" & @CRLF & _
"\item $M$ is cancellative;" & @CRLF & _
"\item $(M, \le_L)$ and $(M, \le_R)$ are lattices;" & @CRLF & _
"\item there exists an element $\Delta \in M$, called {\it Garside element}, such that the set " & @CRLF & _
"$L(\Delta)= \{ x \in M; x\le_L \Delta\}$ generates $M$ and is equal to $R(\Delta)= \{ x\in M; " & @CRLF & _
"x\le_R \Delta\}$." & @CRLF & _
"\end{itemize}" & @CRLF & _
"" & @CRLF & _
"Using the fact that is atomic and that $L(\Delta)= " & @CRLF & _
"\{x \in M; x \le_L \Delta\} M \pi_L(a) \neq 1 a \neq " & @CRLF & _
"1 k \partial_L^k(a)=1 k$ be the" & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)