import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$[^\\$]*\\$";
final String string = "$hello$\n\n"
+ "$\n"
+ "hello\n"
+ "$\n\n"
+ ".projection $I_{d,i} \\rightarrow M_{d,i} M_{d,0}$, where all the\n\n"
+ "\\begin{itemize}\n"
+ "\\item $M$ is atomic and finitely generated;\n"
+ "\\item $M$ is cancellative;\n"
+ "\\item $(M, \\le_L)$ and $(M, \\le_R)$ are lattices;\n"
+ "\\item there exists an element $\\Delta \\in M$, called {\\it Garside element}, such that the set \n"
+ "$L(\\Delta)= \\{ x \\in M; x\\le_L \\Delta\\}$ generates $M$ and is equal to $R(\\Delta)= \\{ x\\in M; \n"
+ "x\\le_R \\Delta\\}$.\n"
+ "\\end{itemize}\n\n"
+ "Using the fact that is atomic and that $L(\\Delta)= \n"
+ "\\{x \\in M; x \\le_L \\Delta\\} M \\pi_L(a) \\neq 1 a \\neq \n"
+ "1 k \\partial_L^k(a)=1 k$ be the\n";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}