# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([TtEeGgiHu]{2}[0-9/()G]+)\s+([\S]+)\s+([\S]+)\s+(.+\n)"
test_str = ("Gi0/0/0/7 up up Conexao ao RTACRJO0104 [Gi0/0]\n"
"PO0/0/3/0 down down Conexao ao RTECCPS0101 [POS4/0] BBIP-PTA ## 70NQT5049 NQT ## - DESATIVANDO\n"
"PO0/0/3/1 up up Conexao ao RTECVRD0101 [POS3/0] // VRDRJOCPL030194 ACCID 029524\n"
"PO0/0/3/2 up up Conexao ao RTECCPS0101 [POS4/0]\n"
"PO0/0/3/3 admin-down admin-down \n"
"Te0/1/0/0 admin-down admin-down Conexao ao RTICRJO0101 [Ten0/0/0/4]\n"
"Te0/1/0/1 admin-down admin-down Conexao ao RTICRJO0102 [Ten0/4/0/12]\n"
"Te0/1/0/2 up up Conexao ao RTEDRJO0101 [xe-0/2/0]\n"
"Te0/1/0/13 up up Conexao ao RTEDRJO0101 [xe-0/3/0]\n"
"Hu0/2/0/0 up up Conexao ao RTICRJO0101 [HundredGigE0/1/0/0]\n"
"Hu0/4/0/0 up up Conexao ao RTICRJO0101 [HundredGigE0/1/0/0]\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.