import Foundation
let pattern = #"(?<=(?:sin|cos|tan)\([^)]*)x"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"f(x+1)+g(x)+2x-sin(x+1)+2cos(3x)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"x°"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)