package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([a-zA-Z0-9_\-\.]+)@ves\.ac\.in$`)
var str = `name-number@ves.ac.in`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}