$re = '/.*buero(.*)$/m';
$str = '0_userdata.0.mqtt.1.shellies.licht.buero.computer.temperature';
$subst = "0_userdata.0$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;