re = /.*buero(.*)$/m
str = '0_userdata.0.mqtt.1.shellies.licht.buero.computer.temperature'
subst = '0_userdata.0$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result