import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Version\\s(\\d+\\.\\d+(?:\\([^()+]\\)[A-Z]\\d|\\.\\d{2}[a-z]))";
final String string = "String 1-Cisco IOS Software, C3900 Software (C3900-UNIVERSALK9-M), Version 15.4(3)M3, RELEASE SOFTWARE (fc2)\n"
+ "ROM: System Bootstrap, Version 15.0(1r)M16, RELEASE SOFTWARE (fc1)\n\n"
+ "String2-Cisco IOS XE Software, Version 16.05.01b\n"
+ "Cisco IOS Software [Everest], ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.5.1b, RELEASE SOFTWARE (fc1)\n"
+ "licensed under the GNU General Public License (\"GPL\") Version 2.0. The\n"
+ "software code licensed under GPL Version 2.0 is free software that comes\n"
+ "GPL code under the terms of GPL Version 2.0. For more details, see the";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}