import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*?\\d{8}_){1}.*?(\\d{8})";
final String string = "XXXXX_20160207_20180208_XXXXXXX_20190408T160742_xxxxx\n"
+ "XXXXX_20160207_XXXXXXX_20180208_20190408T160742_xxxxx\n"
+ "XXXXX_20160207_XXXXXXX_20190408T160742_xxxxx\n"
+ "20160207_20180208_XXXXXXX_20190408T160742_xxxxx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}