package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+\.?\d*)\/(\d+\.?\d*)`)
var str = `This is Logan, the Chow who lived. He solemnly swears he's up to lots of good. 9.75/10
./.
1/100
0.99/10.0
/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}